您当前的位置: 首页 > 网站编程 > PHP教程 > php版本导致shopex4.8.5安装的问题

php版本导致shopex4.8.5安装的问题

作者:不详 来源:网络 发布时间: 2014-08-18 14:33 点击:
相信很多人都遇到了和我一样的问题:php5.3以上的版本不再支持Zend Optimizer,但是shopex之类的网站必须要高版本的Zend才能用。 经过了n个小时悲催的摸索,终于搞定了,但是最终也只能向shopex屈服了 首先,PHP5.3.x版本如果想使用Zend Guard Loader,必须下载NTS的版

php版本导致shopex4.8.5安装的问题

  相信很多人都遇到了和我一样的问题:php5.3以上的版本不再支持Zend Optimizer,但是shopex之类的网站必须要高版本的Zend才能用。

  经过了n个小时悲催的摸索,终于搞定了,但是最终也只能向shopex屈服了……

  首先,PHP5.3.x版本如果想使用Zend Guard Loader,必须下载NTS的版本,而且必须是VC9编译的。这两点一定要注意,有一个不对都没法用Zend Guard Loader。

  目前wampserver 2.1e(32位版)自带的php5.3.5是VC6编译的,所以wampserver 2.1e环境是不能直接用Zend Guard Loader的。wampserver 2.1d(64位版)自带的php5.3.4是VC9编译的,但是却是TS版的,所以也不能用。

  如果想用新版本的php+zend guard,那就只能去php网站下载一个nts版本的vc9编译的php了。

  不过,就算你用新版本的php和zend guard,也不能用shopex4.8.5,会因为zend版本问题解析出错。

  因此,为了用这个版本的shopex,只能被逼换成php 5.2.x版本+Zend Optimizer 3.3.3了。

  当然,这里也要注意,PHP 5.2.17必须要TS版本的VC6编译的才能和Zend Optimizer 3.3.3配合,真他娘的变态!

  最后,弄好了这个环境之后终于可以安装shopex了。但是,安装的时候在新建数据库的过程中总是进行不下去。

  查看mysql数据库发现只有97个表,而完全安装好的话应该是109个表。查了好多地方,也不知道哪里的问题。

  最后终于找到了原因,是mysql版本太高造成的。然后从Mysql 5.5.8退到Mysql 5.1.55就正常了。
分享到:
本文"php版本导致shopex4.8.5安装的问题"由远航站长收集整理而来,仅供大家学习与参考使用。更多网站制作教程尽在远航站长站。
顶一下
(0)
0%
踩一下
(0)
0%
[点击 次] [返回上一页] [打印]
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 密码: 验证码:
关于本站 - 联系我们 - 广告合作 - 网站声明 - 友情连接- 网站地图 - 站点地图 - 返回顶部
Copyright © 2007-2013 www.yhzhan.com(远航站长). All Rights Reserved .
远航站长:为中小站长提供最佳的学习与交流平台,提供网页制作与网站编程等各类网站制作教程.
官方QQ:445490277 网站群:26680406 网站备案号:豫ICP备07500620号-4